widgetkit

Blog artikelen met het kenmerk widgetkit


Widgetkit en JCE gaan niet goed samen


Na het uitvoeren van wat updates kwam ik erachter dat ik mijn YooTheme's Widgets niet meer kon aanpassen.

De vraag is dan altijd, komt dit door de laatste versie wijziging of was dat hiervoor ook al, want wanneer had ik er ook al weer voor het laatst wat mee gedaan?

Na zoeken op internet kwam ik er in elk geval achter dat anderen een soortgelijk probleem hadden en dat het in hun geval kwam door de combinatie van een JCE script en YooTheme's Widgetkit. De versie van JCE waar deze problemen mee gemeld werden, was versie 2.0.20.

Ik had geupdate, en mijn JCE versie is 2.2.4, YooTheme's Widgets versie 1.2.1 en ik had gehoopt, dat deze gemelde problemen inmiddels wel waren verholpen.

Helaas...

Ik heb uiteindelijk JCE en Widgetkit compleet ge-deinstalleerd. Daarna Widgetkit weer terug gezet, al mijn widgets weer aangemaakt, en alles werkte goed, behalve dat ik geen editor meer had.

Dus JCE 2.2.4 er maar weer opgezet. En helaas, onmiddelijk is het aanpassen van een widget onmogelijk geworden en valt hij bij elke wijziging die je probeert aan te brengen, terug naar de "default" style, en width en heigth "zero".

Het enige wat helpt om weer een widget te kunnen aanpassen, is JCE verwijderen. Het uitschakelen van de editor in of de algemene instellingen, of de user-instellingen, is helaas niet voldoende.

Op de forums van JCE en YooTheme is wel het eea gemeld, en het schijnt te maken te hebben met de nieuwste TinyMCE versie die sinds JCE 2.0.20 in JCE is opgenomen.

Meer informatie hier:

JCE 2.2.2 and Widgetkit 1.1.1

De oplossing waarover gesproken wordt is hier te vinden:

Widgetkit v1.0.5 vs JCE editor

Ik heb deze uiteraard in mijn versies uitgeprobeerd, maar helaas....


Dus vooralsnog zit ik zonder JCE editor.


:::niet blij:::